Need help? Email support@trainerroad.com

Can't Log Into Application

Password/Username

An incorrectly input username or password are the two most common reasons behind a user's inability to log in. First, make sure there aren't any typos in your username and password.

 

 If you forgot your password, you can reset your password by following these instructions.

 

Web Connection

The TrainerRoad application needs access to the Internet once every 30 days to verify you're an active user. If you haven't logged in for a while with a Web connection, connect to the Internet and then try logging in again.

 

Can't Log in from a Windows Machine? 

You may see a message that says "Cannot connect to trainerroad.com". Windows machines make applications utilize Internet Explorer when connecting to the Internet. Thus, you'll need to check that all of the settings are correct within IE (even if you don't use IE as your main browser).

Here's what you'll need to do:

1. Open Internet Explorer

2. Go to "Internet Options"

3. Select the tab marked "Advanced"

4. Scroll down to "Security"

5. Make sure that "Use SSL 2.0/3.0" and "Use TLS 1.0" are checked

 

Check Firewalls

Some firewalls may be set up such that they are blocking access to our website and disallowing the TrainerRoad app from connecting to the server. Check your firewall's settings to make sure that TrainerRoad is not a blocked site.

 

If you still cannot log in, contact our support team at support@trainerroad.com.

 

 

 

 

Have more questions? Submit a request

Comments

  • Avatar
    Dirk Pauley

    This worked for me after having trouble for along time and looking this up. After much frustration and not having or taking the time to look into this before I can now get my custom workouts to another computer and suffer even more. Oh the joy!

  • Avatar
    Jerry Weiss

    The solution for "can't connect" from a windows machine worked. #$%^&*( windows

  • Avatar
    steven wise

    When I try to log in from the application v2.7.5 mac OS X El Capitan 10.11.4 the message bottom right of the app window says 'Saving account...' but does not change or log in.

    Any help appreciated. Thanks

Powered by Zendesk